Csv import for members leaves "first name" empty

I am using Silverstripe 4.1 and like to import user data via the csv import function in the “security” section.

No matter what i do or how i format my csv file, the first field “First Name” stays empty, all other fields work correctly.
Even if i enter a member via the cms, export it, delete the member in the cms, import the csv again - the “First Name” is empty.

Do you have any ideas?

1 Like

See: Exported members CSV has broken 'First Name' column · Issue #7081 · silverstripe/silverstripe-framework · GitHub

There is a known issue where the export uses a column name “First Name” (note the space) but the import is looking for a field called “FirstName” (note no space).

You’ll need to modify the CSV header row to make sure the “First Name” column does not have a space.

I had a similar problem a few days ago. I had to save the csv file as utf-8 without BOM. That did the trick for me.

I just tested with re-importing a modified export csv, you’re right, FirstName is empty. I think this is a bug. Can you create an issue?

However with this demodata it works:


1 Like

I came accross this recently albeit not using FirstName. I found that the first column regardless of what it was is ignored.

To resolve it I added a dummy column as the first column in the csv

1 Like

It is definitely a problem with the first column not accepting a space.

I just try to import a .csv with first column “Product Code” which didn’t work, but when I did change it to “ProductCode” it worked.
All other columns worked with spaced names.

It must have been an old problem as I was doing it on SilverStripe 3.6.6 version.

**Update: ** It did work when I manipulated the csv file itself. It didn’t work when I tried to upload a csv file that already had the non-spaced version in it. I had to open the csv file and save it again - probably to confirm the spelling? - then it worked.