Disable cache parameter for assets [?m=]

**Silverstripe Version:**5.2.0
**PHP Version:**8.3.0

**Question:**How to disable assets parameter for caching ?m=xxx


I would like to turn off this function for adding the cache parameter ?m=xxx for my assets, couse i use my own function so i load assets like this:


This “myOwnFunction” return simple ?v=xxx

And in _config.php i set this:

use SilverStripe\View\Requirements;


And i made /dev/build/?flush=1, i restart my apache2, i disable cache in browser, i clean all of data from browser, i used parameter like ?v=test to avoid browser cache and this parameter still exist… and i get something like this:


There is any additional cache and i missed something? I even try to set env to prod and than made /dev/build/?flush=1

Please help me couse i’ve lost my patience. :)))

What happens if you put the Requirements::set_suffix_requirements(false); call in your PageController’s init() method?

Or you could use & instead of ? at the start of your function’s output.

This does sound like it might be a bug though, so if you can reproduce it with a fresh installation of silverstripe/installer feel free to open an issue on GitHub.