Embedded video not playing due to change to installation of SSL certificate on site


#1

Silverstripe Version:
Framework 3.1.6 CMS 3.1.6
Question:
I’m trying to help a friend out with their website, they recently moved to a new hosting service and have installed an SSL certificate on the site. This has stopped the video on certain pages from showing.

See example at the bottom of this page Elliott 6M | Elliott Marine

I’m assuming I just need the embedded Youtube link to be HTTPS but I’m unsure how best to do this.

I tried adding to the whitelist of HTML tags so I could insert the entire HTTPS address in the CMS but that didn’t work.

‘embed[src|type|pluginspage|width|height|autoplay],’ .

I also tried editing Oembed.php file but I’m completely out of my depth here.

I’ve not worked with Silverstripe before so I don’t know what I need to edit. Currently the CMS just takes the Youtube video ID and if I insert the entire address HTTPS and all it doesn’t make any difference.

What would be the best thing for me to do?

'embed[src|type|pluginspage|width|height|autoplay],' .

#2

Not sure if you’ve already fixed it, but the video on that page plays just fine for me.

It’s quite bad form to autoplay video on a page, so if that’s what you’re asking then to be honest, you’re better off the way it is now :slight_smile: