Installation error: the requested php extension intl is missing

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Hi, trying to install a new fresh version of silverstripe. Using Mac CLI in to install. Getting a huge list of quite similar errors. Error - silverstripe/framework 4.x-dev requires ext-intl * -> the requested PHP extension intl is missing from your system.

Anyone that has a solution for this?

Hi,

Sorry for stating the obvious… you need to install the PHP intl extension. I’m not sure how you need to do that, as I don’t know what setup you’re using for the web server. Google should be able to help out though.

Hi. I am running php 7.3.9 MAMP on mac. The intl file should activated by default. I did try to install it manually as well. But does not work.

In case you’re not aware, the PHP version which is used when serving web pages may not be the same as the one being used by the CLI, so it may be the case that intl isn’t present in the command line.

Running php -m in the command line should show you which modules are installed.

Thanks for the tip. I did run php -v in the CLI. And it’s the same version. Well I have to do some digging.

Try compsoer install with --ignore-platform-reqs flag. If you install it via mac cli composer will look at your system setting rather than the mamp settings. That should work.