Is SilverStripe 3 & 4 mysq5.7 compatible yet?


#1

Silverstripe Version:

  • SilverStripe 3.7+
  • SilverStrip 4.4+

Question:
Is SilverStripe 3 & 4 mysq5.6 compatible yet?

Just wanted to know.

Cheers
Leo


#2

The latest versions should be, yes. I’m running the latest MariaDB with no issues.


#3

MySQL 5.6+ is officially supported. That includes 5.7 as well. As long as Oracle doesn’t break too much in further major versions, everything should work fine. AFAIK MySQL 8.0 works nicely as well as MariaDB 5.5 and 10.

If you find any issues with the versions >= 5.6, please don’t hesitate to report them as bugs.


#4

Thanks guys!

Cheers
Leo