Locked out for 15 minutes

I’m trying to get into my own development install of Silverstripe 4. Dev environment. I used to be able to get in but today I am locked out and I have no idea why. I also get a “you have been locked out for 15 minutes” type message.

So far I’ve tried setting SS_DEFAULT_ADMIN_USERNAME and SS_DEFAULT_ADMIN_PASSWORD in the .env file and that makes no difference (odd because it usually works)

I’ve tried playing with the LockedOutUntil field in Member, setting it to null.

I’ve tried copying Member records from another install (where I know the password) and that doesn’t work either. I still get the 15 minute sin-bin.

I need to get in but I’ve run out of ideas. How do I turn off this 15 minute thing anyway? I’m also a bit worried that my install seems to be ignoring settings in the .env file (the site looks fine, so it’s connecting the the DB)

I have not set the timeout in the .yml file. Would that make any difference?

If I ask for the password reset email, I get it, and it allows me reset the password. I can see from the LastEdited field on the record that the update worked. But even so I am told that the credentials are not correct.

I’ve also tried deleting the cookies I found but that didn’t help either.

What else can I do? I would much rather NOT chuck everything and start again.

It’s happening again on another site.

Any ideas?

Have you tried writing the following in the _config.php

1 Like

Good point, sometimes that (somehow) works better than using the .env file.

tbh, I can’t remember if I did that or not. But time was pressing so I simply took a backup of the database and rebuilt everything in a few minutes.

I have a vague feeling it had something to do with the way the admin account is set up (or not) when using Scriptaculous on CPanel.

I’ve gone back to Composer since that.

1 Like