Mod_rewrite not always working on Mac PHP 7.2.10

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

I’m having a problem on 4.2.1, with this message on install even though mod_rewrite is on and AllowOverride All is set.

Friendly URLs are not working. This is most likely because a rewrite module isn't configured correctly on your site. You may need to get your web host or server administrator to do this for you:
mod_rewrite or other rewrite module is enabled on your web server
AllowOverride All is set for the directory where SilverStripe is installed

Even though I get that error I can still navigate to the about and contact pages on a new install. I also have another install which was working yesterday but now I can’t get to some of the pages in the admin. /admin/settings and /admin/properties/ (custom post from the tutorial) works but /admin/pages and individual posts inside /admin/properties/ don’t. I just get the silverstripe preloader logo constantly going with the admin nav on the right.

I’m on Mac and yesterday there was an update in the app store for “Command Line Tools (macOS High Sierra version 10.13) for Xcode.” This broke git-ftp for me, so now I’m wondering if that update may have broken SilverStripe as well.

Seem to be getting this error in my apache log when I load a page that fails:

httpd(1985,0x7fff9e185380) malloc: *** error for object 0x7fb18bd71a98: incorrect checksum for freed object - object was probably modified after being freed.
*** set a breakpoint in malloc_error_break to debug
[Wed Sep 19 14:29:35.051035 2018] [core:notice] [pid 1342] AH00052: child pid 1985 exit signal Abort trap (6)
[Wed Sep 19 14:29:35.051128 2018] [core:notice] [pid 1342] AH00052: child pid 1984 exit signal Segmentation fault (11)
[Wed Sep 19 14:29:36.131720 2018] [core:notice] [pid 1342] AH00052: child pid 1989 exit signal Segmentation fault (11)
[Wed Sep 19 14:29:36.131824 2018] [core:notice] [pid 1342] AH00052: child pid 1988 exit signal Segmentation fault (11)
[Wed Sep 19 14:29:36.131857 2018] [core:notice] [pid 1342] AH00052: child pid 1987 exit signal Segmentation fault (11)
[Wed Sep 19 14:29:36.131887 2018] [core:notice] [pid 1342] AH00052: child pid 1986 exit signal Segmentation fault (11)
[Wed Sep 19 14:29:37.204015 2018] [core:notice] [pid 1342] AH00052: child pid 1990 exit signal Segmentation fault (11)
[Wed Sep 19 14:29:41.421261 2018] [core:notice] [pid 1342] AH00052: child pid 1991 exit signal Segmentation fault (11)

making some progress. SIlverstripe doesn’t like something about PHP 7.2.10 which I also recently updated. I’m on 7.2.2 now and everything works fine. I don’t think that was the version I was on before 7.2.10 though. This PHP version was installed with homebrew. Still messing around with it.

Oh and on the page that was dying, Chrome showed a “ERR_EMPTY_RESPONSE” error.

It’s possibly a missing PHP extension rather than the specific version. If the later version didn’t have something like php-intl installed, then it could be causing problems.

I have had the error message about intl not being installed when installing, and what’s annoying is that I don’t even know how I’ve fixed it, twice now.

Looking at phpinfo(), the only thing that stands out when comparing with silverstripe requirement is the gd section. The requirements list gd2, my phpinfo shows “gd”, but the version is “bundled (2.1.0 compatible)”

Just went through both phpinfos and here’s the list of difference between the 2.

These are modules loaded in 7.2.2 but not in 7.2.10
apcu
http
igbinary
imap
mcrypt
memcached
mongodb
propro
raphf
readline
redis
ssh2
tidy
xdebug

These are modules loaded in 7.2.10 but not in 7.2.2
dba
pdo_dblib
PDO_ODBC
phpdbg_webhelper
sodium

Anything stand out?