newb install issues on postgresql site

Silverstripe 4.6.0

Hi all,
Newb installing on arch linux, with postgresql 12.3, following the instructions at: up-and-running-setting-up-a-local-silverstripe-dev-environment-1, with the exception of using postgresql instead of mysql/mariadb. This is the command I used to install: composer create-project silverstripe/installer example. I ran into the 'Website Error - The website server has not been able to respond to your request" problem and when I loaded up the ‘dev’ SS_ENVIRONMENT_TYPE in .env I ended up with three problems that I hope someone can give me a hand in resolving:

  1. [Notice] Undefined index: args
    Line 124 in ** /my-directory-structure/example/vendor/silverstripe/framework/src/Dev/Backtrace.php**
    123 if ($match) {
    124 foreach ($bt[$i][‘args’] as $j => $arg) {
    125 $bt[$i][‘args’][$j] = ‘’;
    126 }
    127 }

  2. [Warning] Invalid argument supplied for foreach()
    Line 124 in ** /my-directory-structure/example/vendor/silverstripe/framework/src/Dev/Backtrace.php** (same location as previous issue)

and the big one:
3) [Emergency] Uncaught SilverStripe\Core\Injector\InjectorNotFoundException: ReflectionException: Class PostgreSQLDatabase does not exist in /my-directory-structure/example/vendor/silverstripe/framework/src/Core/Injector/InjectionCreator.php:17
11 class InjectionCreator implements Factory
12 {
14 public function create($class, array $params = )
15 {
16 try {
17 $reflector = new ReflectionClass($class);
18 } catch (ReflectionException $e) {
19 throw new InjectorNotFoundException($e);
20 }
22 if (count($params)) {
23 return $reflector->newInstanceArgs($params);
24 }

Each of the problems has a stacktrace a mile long. Happy to add them to the post if it helps. I’m guessing, given the warning and notice headings that it’s only the last issue causing the real grief.

I installed the silverstripe postgresql module by running: composer require silverstripe/postgresql and supplied .env with the name of an existing (newly created) database.

I have php-pgsql installed, and the pgsql and pdo_pgsql extensions enabled in php.ini. I can use psql to access the database so it definitely does exist. If anyone can help, it’s most appreciated.

Have you added the below to your .env file? and also run a after running composer require ...


Hi @christopherdarling,

Thanks for responding.

I did have that line in my .env (though the value was surrounded with quotes).
I did run /dev/build - but without the ?flush=1 param.

Don’t worry about this issue. I have resolved to try a more pgsql-friendly cms.

Thanks again


Back again. :smiley: Seems OctoberCMS is moving to a paid only model.

Install worked better for me this time. I didn’t see errors 2 and 3 (above), but did get the first error before I ran composer require postgresql. So it looks like the ‘Undefined index: args’ error on line 124 of vendor/silverstripe/framework/src/Dev/Backtrace.php relates to not having the pg driver should anyone else come across it.

Apologies for necrobumping, but i figure the resolution may be useful to someone.