problem installing userforms via composer

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

I am trying to install userforms on a SS4 site. When I say

composer require silverstripe/userforms

I am told that

Your requirements could not be resolved to an installable set of packages.

I have tried this on both a PC running Ubuntu server and a live, CPanel site with the same result.

I can install other modules such as spamprotection

Is this some momentary glitch?

Thanks for reading.

Is there any more of the error than that? It’s likely that there are a couple of dependencies which aren’t compatible with each other. Composer should provide some hints as to where the issue lies.

Here’s what I get.
It’s odd to see this happening because I’ve installed userforms heaps of times without a glitch.

vince@server2:/var/www/html/nzo$ composer require silverstripe/userforms
Using version ^5.6 for silverstripe/userforms
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don’t install silverstripe/userforms 5.6.0
- Conclusion: don’t install silverstripe/userforms 5.6.0-rc1
- Conclusion: don’t install silverstripe/userforms 5.x-dev
- Conclusion: don’t install silverstripe/userforms 5.6.x-dev|remove silverstripe/admin 1.3.1
- Conclusion: don’t install silverstripe/userforms 5.6.x-dev|don’t install silverstripe/admin 1.3.1
- Installation request for silverstripe/userforms ^5.6 -> satisfiable by silverstripe/userforms[5.6.0, 5.6.0-rc1, 5.6.x-dev, 5.x-dev].
- silverstripe/userforms 5.6.x-dev requires silverstripe/cms ^4.6 -> satisfiable by silverstripe/cms[4.6.0, 4.6.0-beta1, 4.6.0-rc1, 4.6.x-dev, 4.x-dev].
- silverstripe/cms 4.6.0 requires silverstripe/admin ^1.6@dev -> satisfiable by silverstripe/admin[1.6.0, 1.6.0-beta1, 1.6.0-rc1, 1.6.1, 1.6.x-dev, 1.x-dev].
- silverstripe/cms 4.6.0-beta1 requires silverstripe/admin ^1.6@dev -> satisfiable by silverstripe/admin[1.6.0, 1.6.0-beta1, 1.6.0-rc1, 1.6.1, 1.6.x-dev, 1.x-dev].
- silverstripe/cms 4.6.0-rc1 requires silverstripe/admin ^1.6@dev -> satisfiable by silverstripe/admin[1.6.0, 1.6.0-beta1, 1.6.0-rc1, 1.6.1, 1.6.x-dev, 1.x-dev].
- silverstripe/cms 4.6.x-dev requires silverstripe/admin ^1.6@dev -> satisfiable by silverstripe/admin[1.6.0, 1.6.0-beta1, 1.6.0-rc1, 1.6.1, 1.6.x-dev, 1.x-dev].
- silverstripe/cms 4.x-dev requires silverstripe/admin ^1.7@dev -> satisfiable by silverstripe/admin[1.x-dev].
- Can only install one of: silverstripe/admin[1.6.0, 1.3.1].
- Can only install one of: silverstripe/admin[1.6.0-beta1, 1.3.1].
- Can only install one of: silverstripe/admin[1.6.0-rc1, 1.3.1].
- Can only install one of: silverstripe/admin[1.6.1, 1.3.1].
- Can only install one of: silverstripe/admin[1.6.x-dev, 1.3.1].
- Can only install one of: silverstripe/admin[1.x-dev, 1.3.1].
- Installation request for silverstripe/admin (locked at 1.3.1) -> satisfiable by silverstripe/admin[1.3.1].

Installation failed, reverting ./composer.json to its original content.

Well, it looks like the version of userforms is requesting a higher version of code than you currently have.

Can you confirm the versions you have installed for the core code? (framework, admin, etc.)

(Apologies if you already know this, but composer info will give you the details.)

Silverstripe CMS 4.6.1 has just been released, so if this is a development site, it’s probably worth bumping your base code to that release and retrying the userforms installation.

Ohhh! THANK YOU! :slight_smile: I thought that the error meant the userform files had been renamed or something very unlikely like that.

Yup, updating SS sorted out the problem, thanks again.