Problem local Install with Vagrant / ScotchBox

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

4.8.0

Hello to all,

I am trying to install Silverstripe locally in the current version.
after several failed attempts with MAMP (MacOs) and XAMP (Win10) (not even wg php intl).
I try again with Vagrant on MacOs in combination with ScotchBox - as also recommended by the creators in the docs.

After several problems, I got Vagrant to run so far, but the SS installation now unfortunately fail because the date.timezone entry in php.ini must be activated. I know what to do (remove the commenting “;” in front of the entry) with a php.ini I have to do regularly, but the actual problem is a much more banal and a strange one:

The install.php shows me:
“Your php.ini file is located at /etc/php/7.0/apache2/php.ini”.

So far so good, actually no problem! But, where is this php.ini in fact?

I can neither edit it via terminal via vagrant ssh using the relative path only, nor locate it manually or via detail search via terminal?! Every dir in- outside OSX -prune other dir, step by step and so on … what a ShowStopper

I really don’t know any further at that point …
With MAMP and XAMP it was no problem, immediately found, edited - done

Would be very grateful for any help!

Thank you very much

For all those who have the same problem - and for years this always seems to hit people regularly - I have for now the following suggestion:

go to root->framwork->dev->install-> install.php5 (php 5 in 2021, seriously?)

and comment out the following lines of code here:

Line 588:

$this->requireDateTimezone(array(
			'PHP Configuration',
			'date.timezone setting and validity',
			'date.timezone option in php.ini must be set correctly.',
			ini_get('date.timezone')

and line 701:

$result = ini_get('date.timezone') && in_array(ini_get('date.timezone'), timezone_identifiers_list());

Then it works …

Note:
Of course it serves a purpose to set the TimeZone to avoid conflicts later at least on prod or live!
But:
It is first of all a test-dev environment, and if you like me just want to try out and make the tutorials of the website, I want to believe that the timezone in the later course will not be the measure of things and again the whole abruptly disturbs.

If someone still has idea to the original problem, it would be great if he could share it here!

Thanks a lot!

I think you can also put this in your src/_config.php

date_default_timezone_set('Europe/Amsterdam');

Hi and thanks for your suggestion!
yes, after the installation was somehow able to complete, it works.
But unfortunately it does not work before installing with the install.php