Problem with installing sake will not work?

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Hi, im trying to install SilverStripe 4.6.1 with composer, that worked fine.
But after that I have to run vendor/bin/sake dev/build to finish install.

This will not work. And I don’t know why.

If I run: php vendor/bin/sake
The Code of the sake is shown

If I run: vendor/bin/sake dev/build
Then the following is shown:
vendor/bin/sake: Permission denied.

Is there any idea what I do wrong?

Thanks and best regards
Funghi

Hi - I found your question because I’ve been having the same problem. I was using a ScotchBox VM and getting the same “permission denied” errors as you. If I tried sudo I got “command not found” instead.

It turns out sake is just a wrapper for “vendor/silverstripe/framework/cli-script.php” - so I was able to make things work by going:

$ php vendor/silverstripe/framework/cli-script.php dev/build

I’m pretty new at Silverstripe so I don’t know if this will lead to other problems down the line, but at least this gets past that hurdle.

Hope that helps you!

Hi,
thanks for your answer. Sometimes solutions are so easy :wink:
Now it worked.

1 Like