Project creation with composer, 404 error

Silverstripe Version: 4.1.0

Tried creating project as per tutorial -

composer create-project silverstripe/installer example

The “
6b080a2b694e8b8e9540c981410a2544953e569337b850.json” file could not be downloaded.

Sure enough when I pop that url in the browser, I get a 404.

I haven’t seen that error before and don’t know if this will help but you could try passing in a version like:

composer create-project silverstripe/installer ~/Sites/example 4.1.*

Thanks, I’ve tried the version now, unfortunately same outcome. Here’s the screenshot of what’s happening, I noticed some content is actually being created.

That seems to be something with packagist and not specifically related to SilverStripe. As it now says it can’t find PHPUnit packages. Are you possibly rate-limited or having a flaky internet connection?

Yeah maybe, I reran my original command and it’s working now. Just have some dependencies to be manually resolved but I can work with that. Thanks for your help!