SilverStripe 4.9 forcing logout in admin area

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Silverstripe Version: 4.9.0

Has anyone else noticed an issue with being logged out from the admin in SS 4.9. Whenever I publish I get logged out and directed to the login screen. Rolling back to 4.8 solved the issue for me.

Not something I’ve noticed on the sites I’m currently building, no.

Did this start happening after an upgrade or with a new install?
What’s the server environment?

Have you tried clearing out all the caches, maybe even blitzing the vendor directory and running a composer install ?

it was a new install on local wamp server. i will also try a fresh install without any extra modules. thanks for the suggestions.

I narrowed it down to this module: https://github.com/SilverStripers/elemental-seach. Not sure what the actual cause is yet but it probably has something to do with how this module renders the page to create the search doc. SS may be noticing it and killing the login session.

I use this in my config file:

SilverStripers\ElementalSearch\Model\SearchDocument:
  use_only_x_path: true
  search_x_path:
    - main-content

What do you all do for search when using Elemental?

Seems like calling Director::test() is doing something to the session.

I have opened an issue : https://github.com/SilverStripers/elemental-seach/issues/20

2 Likes