Silverstripe installation - using composer with WAMP

Doing my best here. Following the instructions from:

Now admittedly, I am using WAMP 3.2.6 64 bit.
Because I am having difficulties I simply cannot explain, I’m following the tutorial verbatim:

composer create-project silverstripe/installer my-project
  1. I get this warning: Package swiftmailer/swiftmailer is abandoned, you should avoid using it. Use symfony/mailer instead.

  2. I also get:
    44 package suggestions were added by new dependencies, use composer suggest to see details.

Upon using ‘composer suggest’ I see
C:\wamp64\www>composer suggest
Composer could not find a composer.json file in C:\wamp64\www
To initialize a project, please create a composer.json file. See Basic usage - Composer

  1. Followed the tutorial verbatim. Worked. Changed the name of the folder (from my-project to myx-project) and then I’ve somehow impacted the installation. The theme no longer appears to work and I’m getting an unsupported browser message in the CMS. Change the name of the folder back, and works again.

Does something rely on the folder name? Does this mean should I deploy the site I’m building it will need the same folder name on the server?

Using it as a basis to go through older Silverstripe legacy code to update/upgrade it. So far so good. Then one of the Pages in app/src seems to be creating an Internal Server Error. That’s all I get in the CMS itself. How can I find out what the error actually is so I can fix it?

Put this at the top:
use SilverStripe\Forms\HTMLEditor\HtmlEditorField;

And now I get my error :slight_smile: Has something to do with TextAreaField

This is expected - Unfortunately swapping to synfomy/mailer in CMS 4 would be a breaking change, so CMS 4 will always use the abandoned swiftmailer package - but we’ve swapped to symfony/mailer for CMS 5.

No - however, the cache may have absolute paths in it which it discovered when you first booted up the site. Try running a flush (either visiting /dev?flush=1 in your browser or using vendor/bin/sake dev flush=1 in your terminal) after changing the folder name.

When you deploy to production you won’t have your dev cache in there (unless you’re doing something really weird) so you shouldn’t see this behaviour at all when you deploy.

You can look at your server logs, enable logging from Silverstripe, use a debugger like xdebug, check for errors in the network tab of your browser… there are plenty of ways to find error messages and their causes.
If you want help specifically with the TextAreaField error you’re getting it’s probably best to open a new topic, since that doesn’t seem related to the original purpose of this topic.