SOLVED :: Why do I get 404 after forcing to https


#1

Silverstripe Version:
4.2.1
Question:
Why do I get 404 after forcing to https

Hi, I set up a SS4 Site on a subdomain, while the SS3-Version is running under the main domain with https. Now to get it the SS4 productive I made the main domain linking to the SS4-Folder instead of the SS3-Folder. That works fine. But now after forcing SSL, Silverstripe does not find any document. (404)
The Site appears with the navigationpoints etc. But a document not found is shown. It seems like mod_rewrite is not working corretly. But it worked for SS3…

Any help apreciated
thanks in advance
Fabian

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.domain.com/$1 [R,L]

#2

Did you have a look at Redict from www.mysite.dk to https://www.mysite.dk
Did you set SS_BASE_URL in your .env file. Could it be that you removed RewriteRule ^(.*)$ public/$1 from your .htaccess?


#3

Hej Greg, thanks for youre reply.
Yes I set SS_BASE_URL and kept the code in root/.htaccess

I found a solution now:

  • found that advice in several threads: .htaccess + index.php in /public should have chmod 644
  • and for me: linking my domain directly to /public instead of the silverstripe-root-folder made it working