SS 4.3.3 new installation - no admin password


#1

Silverstripe Version: 4.3.3

**I created new website with SS4.3.3 via composer. Normal installation in browser, when installed there was no styling (simple theme) and when I try to log in I get an error message. Checked db and the field for password is empty. I wonder what happened as I can’t see anybody else reporting an issue. **

I installed it locally on my WAMP (php 7.1.9) as usual and the installation process was as usual. I wonder if this is a bug, but then I would imagine somebody else had the problem before me as this version has been released over a month ago.
I am not sure if that is related, but I recently upgraded from version 4.2. to 4.3.3 and was wondering that I couldn’t log in as well. As I couldn’t remember the steps I took to do so, I am not sure where the error happened so I thought it was me doing something wrong, but maybe it is related, that the password gets deleted.

Had really nobody else that problem? I actually deleted everything and installed it again and had the same error…


#2

Do you have an .env file and did you set SS_DEFAULT_ADMIN_PASSWORD, SS_DEFAULT_ADMIN_USERNAME there?


#3

Hi Greg_808,

Thanks for your answer.

No, I didn’t set the SS_DEFAULT_ADMIN_PASSWORD, SS_DEFAULT_ADMIN_USERNAME in the .env file. I set it on the installation screen, which worked fine in the SS3.x versions.
I think it is the first time that I used a 4.3.x version from scratch. All others were upgrades from existing websites. (I created the project using composer, so should be fine.)


#5

Thanks Greg_808,
I set those

in .env file, but then I still couldn’t log-in into the cms. I got that frozen screen again, which indicated that the theme files weren’t exposed. So I ran the composer vendor-expose which came back with a RuntimeException vendor\silverstripe\admin\client\dist does not exist and could not be crea ted.. I than tried the ‘composer vendor-expose copy’, but this didn’t help either.
I ended up downloading the .zip file, deleted the public folder and copied & pasted the public folder from there.
Now, I can access the cms and have actual styling. I set the .method file back to ‘auto’, so my styling will hopefully get exposed automatically.

I obviously missed the part of the default admin settings in the .env file along my way. Not sure in which version of SS its been introduced.
So, thank you Greg_808 for pointing this out!

Can anybody tell me what other part I missed, so next time I will have the theme folder exposed automatically?

Thank you very much.


#4

As far as i know you got to have an .env file on the server or you can set “first class” environment variables. So no mather where you set them check your .env file if SS_DEFAULT_ADMIN_PASSWORD, SS_DEFAULT_ADMIN_USERNAME is set. Here you have docs https://docs.silverstripe.org/en/4/getting_started/environment_management/ that explain what i mean. I use a pre configured Vagrantbox vor development where environment variables are set allready so i can’t rember if i have ever set veriables on the installation Screen. https://app.vagrantup.com/zauberfisch/boxes/silverstripe-jessie64