SS 4.5: ModelAdmin Delete Record not working

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Silverstripe Version:
(composer info | grep silverstripe)
silverstripe-themes/simple 3.2.0
silverstripe/admin 1.5.0
silverstripe/asset-admin 1.5.0
silverstripe/assets 1.5.0
silverstripe/campaign-admin 1.5.0
silverstripe/cms 4.5.0
silverstripe/config 1.0.18
silverstripe/errorpage 1.5.0
silverstripe/framework 4.5.0
silverstripe/graphql 3.2.0
silverstripe/recipe-cms 4.5.0
silverstripe/recipe-core 4.5.0
silverstripe/recipe-plugin 1.3.0
silverstripe/reports 4.5.0
silverstripe/siteconfig 4.5.0
silverstripe/vendor-plugin 1.4.1
silverstripe/versioned 1.5.0
silverstripe/versioned-admin 1.3.0
symbiote/silverstripe-gridfieldextensions 3.2.2
tractorcow/silverstripe-fluent 4.4.4

Question:
I am using a ModelAdmin to manage two DataObjects. (Both use Fluent Extension).
Inside the CMS (logged in as default admin) I am unable to delete any DataObject.

I can click the delete link in the gridfield and in the detail form, both times it shows a confirm prompt and afterwards the record is still present.

My ModelAdmin Class:

<?php

namespace App\AusbildungenOrteTermine;

use SilverStripe\Admin\ModelAdmin;
use App\AusbildungenOrteTermine\Ausbildung;
use App\AusbildungenOrteTermine\Ort;

class AusbildungsManager extends ModelAdmin
{
    private static $managed_models = [
        Ausbildung::class,
        Ort::class,
    ];

    private static $url_segment = 'ausbildungen';

    private static $menu_title = 'Ausbildungen';

    // @Todo: Disable Import and Export
}

After clicking on:
grafik

A POST Request goes out with the following params:
grafik

After that the record is still present. (Even after a full, cache-skipping reload).

Adding the canDelete Method to the DataObjects and with just a “return true;” has no effect.

I am suspecting a problem with Fluent, because this is the first time I ran into this issue.

Any help is appreciated!

Okay, I just tried my code without the Fluent Package and now the deletion of dataobjects works as expected.

How can I proceed from here? Raise this as github issue on the fluent project?
Go to stackoverflow?

Edit:
I added the logging config from https://docs.silverstripe.org/en/4/developer_guides/debugging/error_handling/

Edit 2:
The problem was or still is with translated dataobjects.
Luckily I found this wonderful extension from bummzack:
https://gist.github.com/bummzack/de3ebec9859101cfa7506b8fa43b21d8

With that it works now as expected.