SS-v2.4.5: Admin Interface does not show up

Hi guys.
I have a serious problem, my admin interface is not coming up any more after successfull login.
This URL/action is triggerd:

Instead of opening /admin a regular page is showing up and tells me that I am logged in as “xyz” and also gives me the opportunity to “Log in as someone else”.

I know it is a outdated version of SilverStripe but it worked all the time and I do not have the time to upgrade it right now. The behavior is occuring after migration to another (old) server which is running php 5.2.14.

I need my admin interface back.
Could you help, please?


1 Like

Did you try to flush the cache?
If you are using a “silverstripe-cache” Folder for caching, try deleting the content of that folder.
Then force a cache regeneration with ?flush=all.

If that doesn’t work (because you need to be logged in) try appending “isDev=1” or set the enviroment to “dev” in your _config.php file.

You could add these to your _config.php

Director::setBaseURL('/'); // <- you might not need this

Hope that helps :slight_smile:

Hi Ironcheese.
Thanks you so much for your help.

I tried all this:

  • delteted the cache dir,
  • set it to dev and run a /dev/buld?flush=all
  • set the base url (without it the base url was doubled in the header)

But without any luck. The admin interface is still not coming up.

I am kind of lost and have no ideas any more what to do.


By the way, I knew a guy called mrcheese from the earlier days in the forums here. Funny, your nick is kind of the same :slight_smile:

Haha yeah! But we are not the same person ^^
Anyway, you could try to delete the “combined” File in the asset folder.

Then: Are you 100% sure you have the right database and the correct password?
Did you try it with the default Admin in your _config file?

I have no file named “combined” in the assets folder, I just have a dir named _combinedfiles/ in this folder. Do you want me to remove this? It is containing leftandmain.js, base.js and cmsmain.js which should be needed by the cms…

I tried all these things I was able to find in the net. I have this in my _config


Security::setDefaultAdmin(‘admin’, ‘xyz’);

I am sure I have the correct db/password, since dev/build?flush=all is working.
I also tried to log in using default admin’s credentials. It shows me “You are logged in as xyz”. So I guess this is working.

I am behind a reverse proxy with my SS-Installation. Do you think there could be a problem with cookies passing through? On the other side: It tells me that I am logged in…

Thanks for your help.

Hm… did you try to reach any Backend URL? Not just “/admin” but “/admin/assets” or “/admin/security”?

Not sure about the proxy, I have no experience with those.
And yes I meant the “combined” folder in assets. As the name says: they get combined. Make a backup first and then delete the whole “combined” folder. Then flush again.

When I enter for example, it leads me to the login form, I am able to log in and after hitting “log in” it just shows up with the hint “You are logged in as xyz” but does not redirect to the admin interface with this URL: (which is shown in the browser url area).

Same behavior after moving assets/_combinedfiles/ out of the webspace…

I was using dev/build?flush=all before both tests…

I have an internal area at the website for members only.
It has exactly the same behavior - it does not redirect, impossible to use it.

mod_rewrite is enabled, rewriting seems to work also since my urls show up in a friendly manner, like and not like or something else.

This is my .htaccess out of the website root:

<Files *.ss>
    Order deny,allow
    Deny from all
    Allow from

<Files web.config>
    Order deny,allow
    Deny from all

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>
    RedirectMatch 403 /silverstripe-cache(/|$)
SetEnv HTTP_MOD_REWRITE On RewriteEngine On RewriteBase /
    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]