Subdirectory install htaccess rewrite 4.3


#1

Silverstripe Version: 4.3

Question:

Can you tell me the last line of the rewrite rule? As it stands, its index.php. Shouldnt it be subdirectory-name/index.php

Install doesnt complete. It stops at

Friendly URLs are not working. This is most likely because a rewrite module isn’t configured correctly on your site. You may need to get your web host or server administrator to do this for you:

  • Setting up public/index.php
  • Setting up app/_config.php
  • Setting up app/_config/theme.yml
  • Setting up .env
  • Building database schema…
  • Creating default CMS admin account…
  • Checking that friendly URLs work…
  • Friendly URLs are not working. This is most likely because a rewrite module isn’t configured correctly on your site. You may need to get your web host or server administrator to do this for you:
  • mod_rewrite or other rewrite module is enabled on your web server
  • AllowOverride All is set for the directory where SilverStripe is installed

RewriteRule .* index.php


#2

Hi @pixelpadre,

You have to change the permissions on /public/index.php & /public/.htaccess from 755 to 644.

Hope this helps you!

Thanks…!


#3

I found that I could not install 4.3 unless I turned off engine rewrite in htaccess and turned it on after install. I think rewrite was creating friendly urls when it shouldnt be.