Themes not showing up anywhere in the CMS so I can change from one to another

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Silverstripe Version: 4.1.1

Question:

I have created a SS 4.1.1. installation at Fastcomet. I tried installing two others besides “simple” that it cam with: Starter (via composer) and highway (via FTP)

I can find nowhere in the new CMS backend where it shows a selection of the themes that are installed. Certainly this all worked well in V2 but does not seem to work at all in v4.

I see no other complaints about his so I assume it is something to do with my installation.

There seems to be a dearth of info on themes for v4 and nothing I have found gives any clue as to how to select one from the other. It is starting to drive me crazy.

Can anyone help please.

Cheers
Pete

Hi Pete, the active theme no longer comes from a user selection but a developer configuration. See Themes – SilverStripe Documentation

WHY?!!?! What a stupid, pointless change. Why do you dev types always, ALWAYS have to make everything needlessly over-complicated? Ugh.

I made this module a while ago when it first disappeared:

That will basically restore the old functionality, on most sites.

Hi Andante

I tried installing your theme picker in a fresh install but alas it did not work and the screen threw a server error. I’m using ss 4.1.1 which seems to be bastard-software-from-hell!!

So I tried to install silverstripe-bootstrap-4 using composer.and after I edited the theme.yaml it lost ALL formatting. I am so NOT impressed.

I’m going to try a few more but I’m about ready to jettison Silverstripe for something that actually works

Cheers
Pete

1 Like