Upgrade from 4.0.3 to 4.1.0 Unspported browser message

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Silverstripe Version: 4.1.0 (coming from 4.0.3)

Question: I have just upgraded from 4.0.3 to 4.1.0 (not changing directory structure to use public). CMS works but I am getting an Unsupported browser message

I have just upgraded from 4.0.3 to 4.1.0. I have not created a public directory as that is not doable with my hosting. Even though I am using latest Chrome I am getting a message “Unsupported browser”. The CMS seems to work fine regardless.

This does not appear on my local test machine only on the uploaded hosted version. I use beam to upload the site.

What have I done wrong?

1 Like

I’m getting a similar problem. Set up a new local site - MacOS, Apache 2.4, PHP 7.1 all works fine, including the CMS.
Move to hosted site and the web pages look fine but I get an unsupported browser message when I try to access the CMS. It looks like the Stylesheets are not being found for the CMS.

A typical stylesheet href looks like this:

This works locally but not on the hosted server.

I have clearly missed something somewhere.

cheers
Bruce

I think it has to do with the /resources folder (or /public/resources) which contains links to files in /vendor
I used beam up test --working-copy which seems to upload the files in /resources. I am getting a working CMS but still the Unsupported browser message to the right of the screen.

Refresh. It’s a known issue to the team. If it keeps appearing, try running composer vendor-expose in your project.

@Firesphere Is it a known issue? Do you have a URL?

The stylesheet HTML you tried to paste got stripped, you have to put it into backticks (Markdown). Copied it from your raw forum post: <link rel="stylesheet" type="text/css" href="/resources/vendor/silverstripe/admin/client/dist/styles/bundle.css?m=1522364787">

I’m not too familiar with beam, but assume it does an rsync via SSH? Which rsync flags are you copying with? It has some ability to retain relative symlinks. If you’re using FTP (which doesn’t support symlinks), you need to use composer vendor-expose copy instead. This means you need to run the command each time you change the stylesheet on your local though (since it’s a copy, not a symlink). So ideally you can fix this within the beam tool.

Assuming you’re using GitHub - heyday/beam: A command line utility for deploying websites to servers, there’s different transfer methods you can configure: beam/src/TransferMethod at master · heyday/beam · GitHub

I made the issue a few weeks ago, but can’t find it anymore?

I am using heyday/beam. It copies the symlinks fine and I get a working CMS backend. I just still get the unsupported browser message in a column to the right of the CMS screen. I am using the latest version of google chrome. I still cannot work out why this is happening only on the uploaded version. Except in the <head> the line

<link rel="stylesheet" type="text/css" href="/resources/silverstripe/admin/client/dist/styles/browser-warning.css?m=1520398250">

is missing from the uploaded version even though that file exists.

A flush=all whilst in the CMS sorted this out

I remember showing it to you even… Weird I can’t find it anymore?

I’m using Transmit on a Mac to upload files via FTP. Ticking the box to ‘Follow symbolic links’ solved the issue for me. I’m guessing that means I keep the symlinks on my local site but they are replaced by copies on the uploaded version?

Thanks chillu for helping to identify the problem.

I’ve mentioned the FTP use case in the upload guide more explicitly: Docs for vendor expose through FTP by chillu · Pull Request #7998 · silverstripe/silverstripe-framework · GitHub

I am aware this has been posted a while back; I was able to resolve this by moving the “_resources” folder from public/ path into the root public_html/ path and all works fine.