URL Segment appends "-2" on save or publish

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Every time I save or publish a Page in the CMS it is appending “-2” to the URL Segment field value. For example, “news” becomes “news-2”.

When it happens, I see the value change in either the SiteTree table or the SiteTree_Live table.

In both tables, there is only one instance of “news”. It’s an edit not a save so what’s up with that.

I’ve tried a ?flush and a dev/build?flush with no change.

Obviously I’ve tried to change the value in the CMS but it changes back to -2.

Other page types that aren’t Page seem fine.

What can cause this? Is there a cache I need to kill?

This happens when another Record has the same URLSegment. Is it possible that this is the case? What about in the SiteTree_versions table. Is there an old record that uses this URL?

I did check that. Truncated the versions table and still persists.

This appears to be route problem.

I have a route of 'news': 'NewsPageController'

And a cms page with a url segment of news also and it sees this as a duplicate.