"Used on" table in the Files section

Silverstripe Version: 4.12


When I go to the “Used on” tab for an image in Files, I get an error “As error occured when loading the data: The string did not match the expected pattern.”

Any ideas how to get this to work? I’ve tried implementing an extension as per https://docs.silverstripe.org/en/4/developer_guides/files/file_usage/
but no luck as it would seem that is for updating how data objects are managed. Even when saving an image in the standard Content field on a page, I would expect that page to turn up in the Used on table, but I still get the error.

Nothing immediately springs to mind that would cause this. I can’t find the string “The string did not match the expected pattern” anywhere in Silverstripe CMS’s core code so I can’t find where the error is coming from… but answers to these questions might help figure out a way forward:

Have you added any customisations to the “used on” functionality?
Does this happen to you for a fresh installation of Silverstripe CMS 4.12?
Is there anything in your error log when this occurs?
Is there any more information in your browser’s developer console or network tab?