WYSIWYG not showing SS4


I’m using webpack and upgrading my silverstripe basebuild to Silverstripe 4, all of the CMS works perfectly but for some reason the WYSIWYG editor is not showing, and there is console errors referring to tinyMCE.

Think it may be something conflicting with webpack and the JS of tinyMCE.

Have attached screenshot:

Thanks in advance.



Is anyone else getting this issue?

Maybe the same issue as here: unable-to-edit-pages-on-a-fresh-install-local-environment.

We ended up editing this file to get things going: \vendor\silverstripe\assets\templates\SilverStripe\Assets\Flysystem\PublicAssetAdapter_HTAccess.ss

changed regular expression to:
RewriteCond %{REQUEST_URI} !^.*\.(?i:css|js<% loop $AllowedExtensions %>|$Extension<% end_loop %>)$

Doesn’t work unfortunately, tried that fix but no luck - doesn’t seem like its the same issue. Im getting some JS console errors referring to tinyMCE and the vendor.js file

I updated a project to SS4.2 today with composer update and it was a bit of a mess. I got some TinyMCE errors right away, but can’t say now if they were the same as you’re getting (especially since you reported having this issue on SS4.0?).

SS CMS ended up at v4.2.1 and SS Framework at v4.1.2. Seemed to be to do with the new ‘recipe’ approach. At some point I’d apparently inlined my requirements and I ended up with a weird soup of incompatible dependencies despited Composer not reporting any problems.

Anyway, I cleared all of the 'silverstripe/' requirements from my composer.json and replaced them with just "silverstripe/recipe-cms": "^4.2.1". Did a composer update and now everything is fine again.

1 Like

@JonoM mate your an absolute HERO! that worked wonderfully for me, been banging my head for months trying to sort this out! Massive thank you

1 Like

Glad it helped you! :grinning_face_with_smiling_eyes: