CMS - File cannot be found - after upload to server

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Silverstripe Version: 4.6

I upgraded from 3.6 to 4.6 locally (on my laptop) with no issues (WAMP).
Now I uploaded everything to the server and my images won’t show neither on front end nor on back end.
They are in the folder and I imported the db, but in the files folder I can only see the name of the image but not the image itself it shows - “File cannot be found” instead.

-> one day later:
This might be similar to this question After migrating SS4, multiple Files not Found in SS4 Assets Admin.

So, I ran the dev/tasks " Migrate File dataobjects from 3.x and successive iterations in 4.x" on the server and I get the same result, only some are now “File cannot be found” and for others it helped to get them to show up.

So now comes the weird part. I investigated the files with the “File cannot be found” and they were indeed not in the assets folder.

Has anybody an idea why that might be?

So, finally I found the error.
As I had the weird situation to have files in CMS which were neither in the db nor in the file system and files in the file system which were in the db weren’t showing I checked the db settings in .env and they pointed to the wrong (former website’s ) db.
So, it was all my fault, sorry for bothering you here ;-).